Z jakimi przeglądarkami współpracuje Plone?

Skoro Plone oparty jest na sieci, z jakimi przeglądarkami współpracuje?

Plone umożliwia dostęp do informacji na swoich stronach wszystkim przeglądarkom, i tak długo, jak przeglądarka nie analizuje i nie interpretuje czegoś czego nie potrafi obsłużyć, jest w niej w pełni funkcjonalny. To oznacza, że można odczytać zawartość, dodawać treści i wykonywać wszystkie operacje Plone'a w każdej przeglądarce - choć może to być nieco bardziej kłopotliwe w tych starszych.

Otrzymasz dodatkowe korzyści i łatwość użytkowania, jeśli używasz przeglądarki zgodnej ze standardami. Zdefiniowaliśmy cztery poziomy wsparcia i przygotowaliśmy listę na której przyporządkowaliśmy do nich niektóre z popularnych przeglądarek, tak byś wiedział jakiego poziomu można spodziewać się dla konkretnej przeglądarki.

Cztery poziomy wsparcia Plone'a dla przeglądarek

  1. Dostęp do informacji
    • Wymagania: parsowanie (X)HTML, opcjonalne wsparcie CSS1
    • Udostępnia:
      • Wszystkie informacje i funkcjonalność dostępne dla każdego user agent.
      • Podstawowy wygląd oparty o CSS 1 (tam gdzie dostępne)
  2. Stylowanie wizualne
    • Wymagania: wsparcie CSS2
    • Udostępnia:
      • Pełny wygląd Plone'a
    • Zawiera poziom 1
  3. Dodatkowe elementy interfejsu użytkownika
    • Wymagania: Podstawowe wsparcie DOM2
    • Udostępnia:
      • Menu akcji
      • Widget daty
    • Zawiera poziom 1 i poziom 2
  4. Zaawansowane elementy interfejsu użytkownika
    • Wymagania: Pełne wsparcie DOM2 oraz następujące wbudowane funkcjonalności:
      • XmlHttpRequest
      • contentEditable/Midas
    • Udostępnia:
      • Edytor wizualny treści
      • Pobieranie treści bez odświeżania całej strony
    • Zawiera poziomy 1, 2 i 3

Plone nie zależy od żadnych zewnętrznych wtyczek, Flasha, Javy ani podobnych. Możliwe jest wykorzystanie tych technologii ale nie są one wymagane.

Lista przeglądarek

Określa które przeglądarki należą do którego poziomu.

Poziom 4

  • Internet Explorer 6.0 i nowsze
  • Mozilla and Firefox: 1.0 i nowsze
  • Opera 8 i nowsze (Opera 9 i nowsze dla edytora wizualnego)
  • Safari 2.0 i nowsze (Safari 3 i nowsze dla edytora wizualnego)
  • Chrome 0.2 i nowsze

Poziom 3

  • Safari 1 i nowsze
  • Opera 7 i nowsze
  • OmniWeb 4.5 i nowsze
  • Przeglądarki oparte na Mozilli: ~0.9
  • Internet Explorer 5.5
  • Konqueror 3.2.1 i nowsze

Poziom 2

  • Opera 5 and 6
  • Windows Internet Explorer 5.0

Poziom 1

  • Macintosh Internet Explorer 5.x
  • Netscape 4.x
  • Przeglądarki tekstowe takie jak lynx oraz w3m.
  • Wszystkie inne